BillingPoint Experiencing Issues
Incident Report for Onit
Resolved
We have resolved the issue with our BillingPoint service. Please contact our support team in case you are still experiencing issues.
Posted Nov 26, 2024 - 18:31 UTC
Investigating
We have detected that there is a possible issue with our BillingPoint service. We are looking into this and will provide an update as soon as possible. Sorry for any inconvenience.
Posted Nov 26, 2024 - 18:20 UTC
This incident affected: BillingPoint.