ELM, CLM, Apptitude, Other (North America E9) Experiencing Issues

Incident Report for Onit

Resolved

The issue with our Onit solution has been resolved. If you're still experiencing any problems, please don't hesitate to contact our support team.
Posted May 08, 2025 - 21:11 UTC

Investigating

We're currently investigating a potential issue with our Onit service. Our team is actively working on it, and we'll share an update shortly. We apologize for any inconvenience this may cause.
Posted May 08, 2025 - 21:06 UTC
This incident affected: Onit (ELM, CLM, Apptitude, Other (North America E9)).